# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(\d+)/_$1/gm;t' <<< "jbloggs.1
jbloggs.1212"