const regex = /\.(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(\\d+)', 'gm')
const str = `jbloggs.1
jbloggs.1212`;
const subst = `_$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);