$re = '/\.(\d+)/m';
$str = 'jbloggs.1
jbloggs.1212';
$subst = "_$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;