package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(\d+)`)
var str = `jbloggs.1
jbloggs.1212`
var substitution = "_$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}