use strict;
my $str = 'jbloggs.1
jbloggs.1212';
my $regex = qr/\.(\d+)/mp;
my $subst = '_$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";