#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(\d+)"
Local $sString = "jbloggs.1" & @CRLF & _
"jbloggs.1212"
Local $sSubst = "_$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)