#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:LA(?:2[123]|1[12]|[789])|CA1[012])$"
Local $sString = "LA7" & @CRLF & _
"LA8" & @CRLF & _
"LA9" & @CRLF & _
"LA11" & @CRLF & _
"LA12" & @CRLF & _
"LA21" & @CRLF & _
"LA22" & @CRLF & _
"LA23" & @CRLF & _
"CA10" & @CRLF & _
"CA11" & @CRLF & _
"CA12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")