// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:LA(?:2[123]|1[12]|[789])|CA1[012])$").unwrap();
let string = "LA7
LA8
LA9
LA11
LA12
LA21
LA22
LA23
CA10
CA11
CA12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}