re = /^(?:LA(?:2[123]|1[12]|[789])|CA1[012])$/m
str = 'LA7
LA8
LA9
LA11
LA12
LA21
LA22
LA23
CA10
CA11
CA12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end