using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:LA(?:2[123]|1[12]|[789])|CA1[012])$";
string input = @"LA7
LA8
LA9
LA11
LA12
LA21
LA22
LA23
CA10
CA11
CA12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}