import re
regex = re.compile(r"^(?:LA(?:2[123]|1[12]|[789])|CA1[012])$", flags=re.MULTILINE)
test_str = ("LA7\n"
"LA8\n"
"LA9\n"
"LA11\n"
"LA12\n"
"LA21\n"
"LA22\n"
"LA23\n"
"CA10\n"
"CA11\n"
"CA12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")