#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?P<time_full>\[(?P<time_clear>\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,})\])\s(?P<module>\{(?P<module_name>\w+.\w+):(?P<module_row>\d+)\})(?P<log_message>.*?)(?=\[\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,}\]|\Z)"
Local $sString = "[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1" & @CRLF & _
"Some " & @CRLF & _
" multiline " & @CRLF & _
" text" & @CRLF & _
"[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")