import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<time_full>\\[(?P<time_clear>\\d{4}\\-\\d{2}\\-\\d{2}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\,\\d{1,})\\])\\s(?P<module>\\{(?P<module_name>\\w+.\\w+):(?P<module_row>\\d+)\\})(?P<log_message>.*?)(?=\\[\\d{4}\\-\\d{2}\\-\\d{2}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\,\\d{1,}\\]|\\Z)";
final String string = "[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1\n"
+ "Some \n"
+ " multiline \n"
+ " text\n"
+ "[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}