import Foundation
let pattern = #"(?P<time_full>\[(?P<time_clear>\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,})\])\s(?P<module>\{(?P<module_name>\w+.\w+):(?P<module_row>\d+)\})(?P<log_message>.*?)(?=\[\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,}\]|\Z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1
Some
multiline
text
[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)