re = /(?P<time_full>\[(?P<time_clear>\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,})\])\s(?P<module>\{(?P<module_name>\w+.\w+):(?P<module_row>\d+)\})(?P<log_message>.*?)(?=\[\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,}\]|\Z)/m
str = '[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1
Some
multiline
text
[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end