const regex = new RegExp('(?P<time_full>\\[(?P<time_clear>\\d{4}\\-\\d{2}\\-\\d{2}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\,\\d{1,})\\])\\s(?P<module>\\{(?P<module_name>\\w+.\\w+):(?P<module_row>\\d+)\\})(?P<log_message>.*?)(?=\\[\\d{4}\\-\\d{2}\\-\\d{2}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\,\\d{1,}\\]|\\Z)', 'gms')
const str = `[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1
Some
multiline
text
[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}