use strict;
my $str = '[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1
Some
multiline
text
[2023-03-11 00:00:07,377] {taskinstance.py:1088} INFO - Starting attempt 1';
my $regex = qr/(?P<time_full>\[(?P<time_clear>\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,})\])\s(?P<module>\{(?P<module_name>\w+.\w+):(?P<module_row>\d+)\})(?P<log_message>.*?)(?=\[\d{4}\-\d{2}\-\d{2}\s\d{2}\:\d{2}\:\d{2}\,\d{1,}\]|\Z)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}