#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\.md$"
Local $sString = "web_components_l_avenir_du_web_aujourd_hui.md" & @CRLF & _
"brouillon.txt" & @CRLF & _
"better_errors.md" & @CRLF & _
"generation_teletravail.md" & @CRLF & _
"document.pdf" & @CRLF & _
"ruby_2.md" & @CRLF & _
"cherie_jai_reduce_les_tableaux.md"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")