re = /^.*\.md$/m
str = 'web_components_l_avenir_du_web_aujourd_hui.md
brouillon.txt
better_errors.md
generation_teletravail.md
document.pdf
ruby_2.md
cherie_jai_reduce_les_tableaux.md'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end