// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\.md$").unwrap();
let string = "web_components_l_avenir_du_web_aujourd_hui.md
brouillon.txt
better_errors.md
generation_teletravail.md
document.pdf
ruby_2.md
cherie_jai_reduce_les_tableaux.md";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}