using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\.md$";
string input = @"web_components_l_avenir_du_web_aujourd_hui.md
brouillon.txt
better_errors.md
generation_teletravail.md
document.pdf
ruby_2.md
cherie_jai_reduce_les_tableaux.md";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}