import re
regex = re.compile(r"^.*\.md$", flags=re.MULTILINE)
test_str = ("web_components_l_avenir_du_web_aujourd_hui.md\n"
"brouillon.txt\n"
"better_errors.md\n"
"generation_teletravail.md\n"
"document.pdf\n"
"ruby_2.md\n"
"cherie_jai_reduce_les_tableaux.md")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")