$re = '/^.*\.md$/m';
$str = 'web_components_l_avenir_du_web_aujourd_hui.md
brouillon.txt
better_errors.md
generation_teletravail.md
document.pdf
ruby_2.md
cherie_jai_reduce_les_tableaux.md';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);