# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:0?1|601)/+601/gm;t' <<< "123456789
0123456789
60123456789
+60123..."