#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:0?1|601)"
Local $sString = "123456789" & @CRLF & _
"0123456789" & @CRLF & _
"60123456789" & @CRLF & _
"+60123..."
Local $sSubst = "+601"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)