use strict;
my $str = '123456789
0123456789
60123456789
+60123...';
my $regex = qr/^(?:0?1|601)/mp;
my $subst = '+601';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";