// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0?1|601)").unwrap();
let string = "123456789
0123456789
60123456789
+60123...";
let substitution = "+601";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}