import Foundation
let pattern = #"^(?:0?1|601)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123456789
0123456789
60123456789
+60123...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+601"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)