# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(\b.{1,17}\b))\1/$1\n/g;t' <<< "I want you to do something else instead"