using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\b.{1,17}\b))\1";
string substitution = @"$1\n";
string input = @"I want you to do something else instead";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}