const regex = /(?=(\b.{1,17}\b))\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(\\b.{1,17}\\b))\\1', 'g')
const str = `I want you to do something else instead`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);