use strict;
my $str = 'I want you to do something else instead';
my $regex = qr/(?=(\b.{1,17}\b))\1/p;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";