$re = '/(?=(\b.{1,17}\b))\1/';
$str = 'I want you to do something else instead';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;