import Foundation
let pattern = #"(?=(\b.{1,17}\b))\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I want you to do something else instead"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)