using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<span style=""font-size:22px"" class=""txt-color-(red|black)"">(.+?)<\/span>)";
string input = @"<span style=""font-size:22px"" class=""txt-color-black"">dummy-data</span>
<span style=""font-size:22px"" class=""txt-color-red"">dummy-data</span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}