// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<span style="font-size:22px" class="txt-color-(red|black)">(.+?)<\/span>)"#).unwrap();
let string = "<span style=\"font-size:22px\" class=\"txt-color-black\">dummy-data</span>
<span style=\"font-size:22px\" class=\"txt-color-red\">dummy-data</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}