$re = '/(<span style="font-size:22px" class="txt-color-(red|black)">(.+?)<\/span>)/m';
$str = '<span style="font-size:22px" class="txt-color-black">dummy-data</span>
<span style="font-size:22px" class="txt-color-red">dummy-data</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);