package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<span style="font-size:22px" class="txt-color-(red|black)">(.+?)<\/span>)`)
var str = `<span style="font-size:22px" class="txt-color-black">dummy-data</span>
<span style="font-size:22px" class="txt-color-red">dummy-data</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}