re = /(<span style="font-size:22px" class="txt-color-(red|black)">(.+?)<\/span>)/m
str = '<span style="font-size:22px" class="txt-color-black">dummy-data</span>
<span style="font-size:22px" class="txt-color-red">dummy-data</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end