const regex = /(<span style="font-size:22px" class="txt-color-(red|black)">(.+?)<\/span>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<span style="font-size:22px" class="txt-color-(red|black)">(.+?)<\\\/span>)', 'gm')
const str = `<span style="font-size:22px" class="txt-color-black">dummy-data</span>
<span style="font-size:22px" class="txt-color-red">dummy-data</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}