#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(1[0-6]\d\d|1(?![7-9])\d\d|(?![2-3]\d\d\d)|(?!4000)|4\d\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$"
Local $sString = "4000-12-31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")