import Foundation
let pattern = #"^(1[0-6]\d\d|1(?![7-9])\d\d|(?![2-3]\d\d\d)|(?!4000)|4\d\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"4000-12-31"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}