const regex = /^(1[0-6]\d\d|1(?![7-9])\d\d|(?![2-3]\d\d\d)|(?!4000)|4\d\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1[0-6]\\d\\d|1(?![7-9])\\d\\d|(?![2-3]\\d\\d\\d)|(?!4000)|4\\d\\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$', '')
const str = `4000-12-31`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}