using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1[0-6]\d\d|1(?![7-9])\d\d|(?![2-3]\d\d\d)|(?!4000)|4\d\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$";
string input = @"4000-12-31";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}