import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(1[0-6]\\d\\d|1(?![7-9])\\d\\d|(?![2-3]\\d\\d\\d)|(?!4000)|4\\d\\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$";
final String string = "4000-12-31";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}