re = /^(1[0-6]\d\d|1(?![7-9])\d\d|(?![2-3]\d\d\d)|(?!4000)|4\d\d[1-9])-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01])$/
str = '4000-12-31'
# Print the match result
str.match(re) do |match|
puts match.to_s
end