# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http[s]?:\\/\\/)?www\.(?=.+)//gm;t' <<< "1)lorum ipsum www.goal.com
2)lorum ipsum http://www.goal.com
3)lorum ipsum https://www.goal.com
4)lorum ipsum https://www.goal.com/1234
5)lorum ipsum www."