$re = '/(http[s]?:\/\/)?www\.(?=.+)/m';
$str = '1)lorum ipsum www.goal.com
2)lorum ipsum http://www.goal.com
3)lorum ipsum https://www.goal.com
4)lorum ipsum https://www.goal.com/1234
5)lorum ipsum www.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;