import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http[s]?:\\/\\/)?www\\.(?=.+)";
final String string = "1)lorum ipsum www.goal.com\n"
+ "2)lorum ipsum http://www.goal.com\n"
+ "3)lorum ipsum https://www.goal.com\n"
+ "4)lorum ipsum https://www.goal.com/1234\n"
+ "5)lorum ipsum www.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}