import re
regex = re.compile(r"(http[s]?:\/\/)?www\.(?=.+)", flags=re.MULTILINE)
test_str = ("1)lorum ipsum www.goal.com\n"
"2)lorum ipsum http://www.goal.com\n"
"3)lorum ipsum https://www.goal.com\n"
"4)lorum ipsum https://www.goal.com/1234\n"
"5)lorum ipsum www.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)